Frequently asked questions

Back
What software may I not use?
Regretfully, there is some general and specific software we cannot permit on our customers' webhotels, for the sake of resource usage, security and service stability.

Webhotel is a service for websites, and is not designed for handling other types of services.


General software

Principles

Here are some of the guiding principles for permissible and non-permissible software.

  • OK: software executing briefly via PHP or CGI on the webhotel, or which supports webhotel maintenance on the login server
  • Not OK: software with too long execution time, which uses too much memory (RAM/swap), CPU, intensive disk usage, and/or intensive database usage
  • Not OK: software posing a security risk, sending of unsolicited email (spam), software suited for damaging third parties, or illegal software

About resource limits

Our PHP configuration has default limits that must not be exceeded, and software exceeding these limits may be forcably terminated and deactivated.

CGI software shall adhere to the same limits.

Even if software does not exceed the specific limits, it may still use too much resources, overloading the webserver. Your webpages will no longer work, and neither will any other webpages on the same webserver. In such case, we will temporarily deactivate the webhotel causing the problems.

Other restrictions

The webservers are behind a firewall, which prevents software not using HTTP.

Some types of software is not permitted, no matter what the cause is, regardless of whether it is run on a webserver or login.domeneshop.no. The following list contains examples, and is not exhaustive:

  • Backdoors
  • Bittorrent clients or servers, or other similar distribution services
  • Chat or IRC robots/proxies
  • DoS/DDoS tools
  • File management scripts in PHP or CGI (regardless of language)
  • Firewall circumvention, or attempts to circumvent
  • Insecure software (known security vulnerabilities)
  • Obfuscated/encrypted software that cannot be automatically verified as secure/original
  • Performance tests for max capacity of our servers/computers/lines
  • Port scanners
  • Proxies (e.g. for anonymization)
  • Remote shell via web
  • Root kits
  • Scam software (e.g. phishing)
  • Spam software
  • Spy software
  • Video transcoders
  • Viruses, trojans, etc.

Specific software

The following software is specifically not permitted. Nor is it permitted to use software based on these listed here, except if all security problems are verifiably fixed and documented as fixed.

  • Adminer - MySQL admin tool, used as a backdoor by criminals
  • CcMail from Cicoandcico - no secure version exists, is unmaintained, and not updated since 2005.
  • CuteNews - no secure version exists, is unmaintained, and not updated since 2008.
  • FCKeditor - Replaced by CKEditor in 2010
  • eXtplorer - Joomla extension, fundamentally unsafe software
  • FreeWebshop.org - no secure version exists, is unmaintained, and not updated since 2008.
  • Joomla versions that have no secure versions and are unmaintained, e.g.:
    • 0.x
    • 1.0.x
    • 1.5.x
    • 1.6.x
    • 1.7.x
    • 2.5.x
    • 3.0.x
    • 3.1.x
    • 3.2.x
    • 3.3.x
    • 3.4.x
    • 3.5.x
  • 3.6.3 and older
  • Mambo - no secure version exists, is unmaintained, and not updated since 2008.
  • Openads - no secure version exists, is unmaintained, and not updated since 2008.
  • OpenX - no secure version is readily available, is essentially unmaintained, and not updated since 2012.
  • osCommerce - no secure version exists, extremely bad security history
  • PHP-Fusion - no secure version exists, is unmaintained, and not updated since 2013.
  • PHP-Nuke - no secure version exists, is unmaintained, and not updated since 2007.
  • PostNuke - no secure version exists, officially discontinued July 2009.
  • Shortcode Excec PHP - WordPress plugin, fundamentally unsafe software, the project was removed from WordPress's pages in 2015.
  • ShoutPro - no secure version exists, is unmaintained, and not updated since 2006.
  • sNews - no secure version exists, is unmaintained, and not updated since 2011.
  • TimThumb - WordPress plugin, used by themes until 2009, no safe version exists, and the project was binned in 2014.

  • Avoid this software

    We ask you not to install the following software in your webhotel, as they often cause problems. Users visiting or administering websites with this software risk locking themselves out due to extreme resource usage.

    • All-in-One WP Migration - WordPress plugin for migration of WordPress sites, we recommend Akeeba Backup
    • Backupbuddy - WordPress plugin for backups, we recommend Akeeba Backcup
    • Backup to Dropbox - WordPress plugin for backups to Dropbox, triggers a bug in WordPress that makes tens of millions of error messages within a short time.
    • Better Search and Replace - WordPress plugin, use Akeeba Backup instead when moving WordPress between websites
    • Cherry Plugin - WordPress plugin
    • Cornerstone - WordPress plugin
    • Craft CMS - requires a dedicated or virtual webserver
    • Imagify Image Optimizer - WordPress plugin
  • Thrive Visual Editor - WordPress plugin

  • See also:

    Keyword:  

    Index

    © 2017 Domeneshop AS · About us · Terms & Conditions · About cookies